Stop/Start Broke Again - WTF - Wrangler JL Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-04-2019, 10:37 AM Thread Starter
Junior Member
 
Join Date: Dec 2019
Posts: 1
Stop/Start Broke Again - WTF

A few weeks ago I took my Jeep in because ESS stopped working. They told me the battery had died and they replaced it.

It has only been a few weeks since and my ESS has stopped working again. The message on the display says that the battery is charging. Unfortunately, it seems to be charging indefinitely.

Has anyone else been having this issue? Did they sell me a lemon. The issue clearly isnt the battery.

As much as I hate ESS, the fact that is broken is really irritating me.
Scott Siegler is offline  
post #2 of 3 (permalink) Old 01-02-2020, 10:48 AM
Junior Member
 
CoolToys's Avatar
 
Join Date: Jun 2019
Location: Huntington Beach CA, Incline Village NV
Posts: 10
I have the issue when it sits for long periods. Since I normally drive from the house to the studio, I get the "charging" message most days. If I drive over an hour or keep the main battery on a trickle charger is works - sort of. It won't kick in until the motor is up to temp which I am guessing is for the oil warming/stability.

I have the i4 Turbo.
CoolToys is offline  
post #3 of 3 (permalink) Old 08-19-2020, 12:10 AM
Junior Member
 
Join Date: Aug 2020
Posts: 6
Quote:
Originally Posted by CoolToys View Post
I have the issue when it sits for long periods. Since I normally drive from the house to the studio, I get the "charging" message most days. If I drive over an hour or keep the main battery on a trickle charger is works - sort of. It won't kick in until the motor is up to temp which I am guessing is for the oil warming/stability.

I have the i4 Turbo.
Thanks for this, Cool toys. Been having the same problem.
Lookatmenow is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome